Increased timeouts to api.coingecko.com (/coins/markets)

Minor incident CoinGecko Public API
2023-03-27 09:40 PM +08 · 3 days, 14 hours, 24 minutes

Updates

Resolved

We have lifted the restrictions on /coins/markets as of 30/03 9:00AM UTC and are seeing better responses for blocking spam vs allowing valid API calls.

We will continue to monitor and make revisions.

  • For additional questions and feedback, please reach out to api@coingecko.com.
  • For dedicated infrastructure and availability requirements for your businesses, do refer to CoinGecko Data API plans or get in touch with CoinGecko Enterprise API here
March 31, 2023 · 12:04 PM +08
Update

We are seeing regressions on api.coingecko.com targeting /coins/markets and have disabled this endpoint temporarily.

Other endpoints are operating as usual.

For questions, please reach out to api@coingecko.com.

March 30, 2023 · 09:11 AM +08
De-escalate

We have deployed several changes and observed that api.coingecko.com has stabilized since 11:30 UTC. We are still monitoring for regressions

March 28, 2023 · 10:25 PM +08
Investigating

We have determined this to be a DDOS targeting specific endpoints on api.coingecko.com. Resolution is still underway.

We recommend critical applications to use our Data API Plans for higher availability requirements.

March 27, 2023 · 10:09 PM +08
Issue

We’re seeing a significant increase in abusive traffic to api.coingecko.com and are actively mitigating them at the moment.

Other services are uninterrupted.

March 27, 2023 · 09:42 PM +08

← Back