Issues on marketchart range and OHLC endpoint

Minor incident CoinGecko Pro API CoinGecko Public API
2025-04-23 04:00 AM +08 · 5 hours, 43 minutes

Updates

Update

Backfilling of data between 2025-04-22 20:00:00 UTC and 2025-04-23 01:00:00 UTC has been completed. All services and data, including historical OHLC and MarketChart range, are now fully restored and accurate.

Impact: Live and historical data are fully available across all endpoints.

  • /api/v3/coins/:id/ohlc
  • /api/v3/coins/:id/ohlc/range
  • /api/v3/coins/:id/market_chart (with interval=5m)
  • /api/v3/coins/:id/market_chart/range (with interval=5m)

We appreciate your patience during this incident. A detailed post-mortem will follow. For feedback and other questions, please contact api@coingecko.com or reach out to your CoinGecko API account team.

April 23, 2025 · 03:00 PM +08
Resolved

The issue has been resolved and data services are now operating normally. However, data between 2025-04-22 20:00:00 UTC and 2025-04-23 01:00:00 UTC may still be incomplete due to the earlier disruption. Our team is currently working on backfilling the affected data to ensure accuracy.

The issue stemmed from one of our service providers failing to write new data during the incident time as a result of a failed upgrade on their platform. A post-mortem will be scheduled.

Impact:

  • Live data is now fully available.
  • Backfilling of OHLC and MarketChart range data is in progress.
    • /api/v3/coins/:id/ohlc
    • /api/v3/coins/:id/ohlc/range
    • /api/v3/coins/:id/market_chart (with interval=5m)
    • /api/v3/coins/:id/market_chart/range (with interval=5m)

For feedback and other questions, please contact api@coingecko.com or reach out to your CoinGecko API account team.

April 23, 2025 · 09:12 AM +08
Issue

We are currently experiencing intermittent issues affecting data availability across several parts of our services. This is due to an issue with one of our third-party service providers responsible for real-time data processing.

Impact: OHLC and MarketChart range data are unavailable.

  • /api/v3/coins/:id/ohlc
  • /api/v3/coins/:id/ohlc/range
  • /api/v3/coins/:id/market_chart (with interval=5m)
  • /api/v3/coins/:id/market_chart/range (with interval=5m)

Our team is actively investigating the root cause and working to restore full functionality as soon as possible. We will provide updates as soon as more information is available.

We apologize for any inconvenience and appreciate your understanding as we work to restore full service.

April 23, 2025 · 04:00 AM +08

← Back